Přihlášení

Jméno

Heslo



Nejste členem?
Klikněte sem
a zaregistrujte se.

Zapomněli jste heslo?
Pro zaslání nového
Klikněte sem.

Photo cloud


progeCAD - alternativa AutoCAD ®
Dodavatelem školní verze konstrukčního 2D&3D programu progeCAD Professional je konstrukční a vývojová kancelář SoliCAD, s.r.o.
 Vertikalní menu, vodorovně rozbalovací, třiúrovňové

Logické funkce (KDYŽ)

Trochu teorie:

Pro výpočty můžeme použít nejen vzorce (funkce), které má k dispozici Excel. Můžeme si vytvořit i vlastní. Velice často pracujeme s podmínkami - vzorec sám rozhodne mezi alternativami a podle toho vykoná určitou funkci. K tomu používá Excel logickou funkci - podmínku KDYŽ..
Např:
Chceme zapsat do buňky B2 text velké nebo malé v závislosti na tom,zda obsahem buňky A1 je číslo větší nebo menší než 10.
Řešení: Do buňky B2 zapíšeme funkci: =KDYŽ(A1>10; "velké"; "malé")
A1>10 ...podmínka "velké" ... akce, která nastane, je-li podmínka splněna "malé" ....akce, která nastane, není-li podmínka splněna. Pokud chceme, aby výsledkem byl zobrazený text musíme tento text zapsat do uvozovek!

Pro editaci funkce můžeme použít i průvodce


Je možné vnořovat do sebe i několik podmínek - vytvořit podmínku v podmínce


Např:
Chceme vyhodnotit výsledek součtu a jestli je výsledek moc velký, vypsat, že je moc velký, je-li malý, vypsat, že je moc malý. Zadání zapíšeme do buněk A1 a C1, výsledek budeme zapisovat do buňky E1. Do buňky B2 zapíšeme vyhodnocení. Podívejte se na řešení a zdůvodněte si ho.



Úkol:

Vytvořte dle předlohy v programu Excel tabulku žáků a jejich bodového zisku v písemné práci z matematiky. Vytvořte vzorec, který určí známku v závislosti na získaném počtu bodů. (Do 90 % všech bodů - výborně, do 70% všech bodů - chvalitebně, do 50% - dobře, do 30% - dostatečně , méně nedostatečně.). Do buňky maximální počet bodů je možno zadat různé hodnoty podle typu písemné práce:
(nápověda: - počet procent spočítáme tak, že počet získaných bodů vydělíme maximálním možným počtem bodů a vynásobíme 100)

Ukázka:


Vygenerované za: 0.03 sekund
4,519,440 návštěv